const regex = /\_(?!.*\bby\b).*?$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\_(?!.*\\bby\\b).*?$', 'i')
const str = `Go by the office and pickup milk by the safeway BY_tomorrow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}