re = /\_(?!.*\bby\b).*?$/i
str = 'Go by the office and pickup milk by the safeway BY_tomorrow'
# Print the match result
str.match(re) do |match|
puts match.to_s
end