# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^|[=\s])\K\d{4}(?=\s|$)//gmi;t' <<< "Ack 9876 3456 3467 4578 4567"