$re = '~(?:^|[=\s])\K\d{4}(?=\s|$)~mi';
$str = 'Ack 9876 3456 3467 4578 4567';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;