re = /^\d{1,2}-(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)(-\d{2})?$/
str = '1-Apr-17'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end