const regex = /-\[\s(.+)\s\]-/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\[\\s(.+)\\s\\]-', '')
const str = `[998FA551B]-[FIRE]-[#b.c.friends@fams]-[ My.Life.Story.V99A4.NONE.x4X5p-RIEP ]- my.life.story.v99a4.xrsr-riep
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}