use strict;
my $str = '[998FA551B]-[FIRE]-[#b.c.friends@fams]-[ My.Life.Story.V99A4.NONE.x4X5p-RIEP ]- my.life.story.v99a4.xrsr-riep
';
my $regex = qr/-\[\s(.+)\s\]-/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}