#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<HEADER>#EXTM3U)\r?\n(?:#EXTINF:(?<DURATION>\-?\d+\.?\d+),(?<TITLE>.+)?\r?\n(?<URI>\S+))"
Local $sString = "#EXTM3U" & @CRLF & _
"#EXTINF:10.0," & @CRLF & _
"media_w854021192_21533.ts" & @CRLF & _
"#EXTINF:10.0," & @CRLF & _
"media_w854021192_21534.ts" & @CRLF & _
"#EXTINF:10.0," & @CRLF & _
"media_w854021192_21535.ts"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")