package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<HEADER>#EXTM3U)\r?\n(?:#EXTINF:(?<DURATION>\-?\d+\.?\d+),(?<TITLE>.+)?\r?\n(?<URI>\S+))`)
var str = `#EXTM3U
#EXTINF:10.0,
media_w854021192_21533.ts
#EXTINF:10.0,
media_w854021192_21534.ts
#EXTINF:10.0,
media_w854021192_21535.ts`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}