package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(\d+\.(?:\d+\.)*\d+))`)
var str = `1.000, 1.0.00, 1.0.0.000 10 100 1..1 1.1 1.10 1..1 12.12.12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}