$re = '/(?:(\d+\.(?:\d+\.)*\d+))/';
$str = '1.000, 1.0.00, 1.0.0.000 10 100 1..1 1.1 1.10 1..1 12.12.12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);