$re = '/^[0-9]+(?:\+[0-9]+)*$/m';
$str = '1+2
3
1+22+3
+1+2
1+
a+1+b+c
12+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);