$re = '/^[^[]*|(?<=]).*/m';
$str = 'Notification mail: The synchronization of ExternalDrive job [backup-->veeam] finished.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);