re = /^[^[]*|(?<=]).*/m
str = 'Notification mail: The synchronization of ExternalDrive job [backup-->veeam] finished.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end