package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^POINT\s+\(([0-9\.]+)\s+([0-9\.]+)\)$`)
var str = `POINT (37.62084900000001 55.70915902328764)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}