package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:[a-zA-Z]+[0-9]+[!?]+)+$`)
var str = `a1?a2!`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}