$re = '/^(?:[a-zA-Z]+[0-9]+[!?]+)+$/D';
$str = 'a1?a2!';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);