#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?>{wrapper btnlabel=(?>"|")(.+?)(?>"|")})(.*?){\/wrapper}"
Local $sString = "<p>{wrapper btnlabel="AAA"}zzzzzzzzzzzzzzzzzzzz{/wrapper}</p>" & @CRLF & _
"" & @CRLF & _
"<p>{wrapper btnlabel="Text"}</p>" & @CRLF & _
"" & @CRLF & _
"<table>" & @CRLF & _
"<tbody>" & @CRLF & _
"<tr>" & @CRLF & _
"<th scope="row">123</th>" & @CRLF & _
"<td>1 123</td>" & @CRLF & _
"<td>12 123</td>" & @CRLF & _
"<td>3 123</td>" & @CRLF & _
"<td>1 123 123</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<th scope="row">123</th>" & @CRLF & _
"<td>2700 123.</td>" & @CRLF & _
"<td>1800 123.</td>" & @CRLF & _
"<td>1000 123.</td>" & @CRLF & _
"<td>300 123.</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>" & @CRLF & _
"</table>" & @CRLF & _
"" & @CRLF & _
"<p>{/wrapper}</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")