import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?>\\{wrapper btnlabel=(?>\"|")(.+?)(?>\"|")\\})(.*?)\\{\\/wrapper\\}";
final String string = "<p>{wrapper btnlabel="AAA"}zzzzzzzzzzzzzzzzzzzz{/wrapper}</p>\n\n"
+ "<p>{wrapper btnlabel="Text"}</p>\n\n"
+ "<table>\n"
+ "<tbody>\n"
+ "<tr>\n"
+ "<th scope=\"row\">123</th>\n"
+ "<td>1 123</td>\n"
+ "<td>12 123</td>\n"
+ "<td>3 123</td>\n"
+ "<td>1 123 123</td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ "<th scope=\"row\">123</th>\n"
+ "<td>2700 123.</td>\n"
+ "<td>1800 123.</td>\n"
+ "<td>1000 123.</td>\n"
+ "<td>300 123.</td>\n"
+ "</tr>\n"
+ "</tbody>\n"
+ "</table>\n\n"
+ "<p>{/wrapper}</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}