package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https://www\.waze\.com/ul\?.*ll=[\d.-]+%2C[\d.-]+`)
var str = `https://www.waze.com/ul?place=ChIJj61dQgK6j4AR4GeTYWZsKWw&ll=37.42199990%2C-122.08405750&navigate=yes
https://www.waze.com/ul?place=ChIJj61dQgK6j4AR4GeTYWZsKWw&navigate=yes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}