$re = '/https://www\.waze\.com/ul\?.*ll=[\d.-]+%2C[\d.-]+/m';
$str = 'https://www.waze.com/ul?place=ChIJj61dQgK6j4AR4GeTYWZsKWw&ll=37.42199990%2C-122.08405750&navigate=yes
https://www.waze.com/ul?place=ChIJj61dQgK6j4AR4GeTYWZsKWw&navigate=yes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);