package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ondas)+`)
var str = `onda
ondas
ondass
ondassssssss
ond
on
ondasondasondasondas`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}