re = /(ondas)+/m
str = 'onda
ondas
ondass
ondassssssss
ond
on
ondasondasondasondas'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end