package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(^.*[P|p]*(OST|ost)*\.*\s*[O|o|0]*(ffice|FFICE)*\.*\s*[B|b][O|o|0][X|x]\s*(\d.)*)`)
var str = `post box martin
post box office
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}