re = /(^.*[P|p]*(OST|ost)*\.*\s*[O|o|0]*(ffice|FFICE)*\.*\s*[B|b][O|o|0][X|x]\s*(\d.)*)/i
str = 'post box martin
post box office
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end