# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(X+)(\W)(X+)(\W)(X+)$/(\1)(\3)(\5)/gm;t' <<< "XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX"