use strict;
my $str = 'XXX-XXX-XXX
XX=XXXX^XXX
XXXXX@XX.XX';
my $regex = qr/^(X+)(\W)(X+)(\W)(X+)$/mp;
my $subst = '(\\1)(\\3)(\\5)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";