import re
regex = re.compile(r"https?:\/\/(youtu\.be|(www\.|m\.)?youtube(-nocookie)?\.com)(?P<viddeo_id>\/(.*)([?&]v=[a-zA-Z0-9_-]{11})|((\/attribution|\/oembed).*(v%3D[a-zA-Z0-9_-]{11}))|(\/shorts\/[a-zA-Z0-9_-]{11})|(\/embed\/[a-zA-Z0-9_-]{11})|(\/v\/[a-zA-Z0-9_-]{11})|((\/user)(\/.+1\/)([a-zA-Z0-9_-]{11}))|(\/e\/[a-zA-Z0-9_-]{11})|(\/live\/[a-zA-Z0-9_-]{11})|\/watch\/[a-zA-Z0-9_-]{11}|\/[a-zA-Z0-9_-]{11})", flags=re.IGNORECASE)
test_str = ("http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
"http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o\n"
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
"http://www.youtube.com/embed/0zM3nApSvMg?rel=0\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg\n"
"http://youtu.be/0zM3nApSvMg\n"
"https://youtube.com/shorts/0dPkkQeRwTI?feature=share\n"
"https://youtube.com/shorts/0dPkkQeRwTI\n\n\n"
"http://www.youtube.com/watch?v=-wtIMTCHWuI\n"
"http://youtube.com/watch?v=-wtIMTCHWuI\n"
"http://m.youtube.com/watch?v=-wtIMTCHWuI\n"
"https://www.youtube.com/watch?v=lalOy8Mbfdc\n"
"https://youtube.com/watch?v=lalOy8Mbfdc\n"
"https://m.youtube.com/watch?v=lalOy8Mbfdc\n\n"
"http://www.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
"http://youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
"http://m.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
"https://www.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
"https://youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n"
"https://m.youtube.com/watch?v=yZv2daTWRZU&feature=em-uploademail\n\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
"http://youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
"http://m.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
"https://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
"https://youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
"https://m.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n\n"
"http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
"http://youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
"http://m.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
"https://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
"https://youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
"https://m.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n\n"
"http://www.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
"http://youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
"http://m.youtube.com/watch?v=cKZDdG9FTKY&feature=channel\n"
"https://www.youtube.com/watch?v=oTJRivZTMLs&feature=channel\n"
"https://youtube.com/watch?v=oTJRivZTMLs&feature=channel\n"
"https://m.youtube.com/watch?v=oTJRivZTMLs&feature=channel\n\n"
"http://www.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
"http://youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
"http://m.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
"https://www.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
"https://youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n"
"https://m.youtube.com/watch?v=lalOy8Mbfdc&playnext_from=TL&videos=osPknwzXEas&feature=sub\n\n"
"http://www.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
"http://youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
"http://m.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
"https://www.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
"https://youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n"
"https://m.youtube.com/watch?v=lalOy8Mbfdc&feature=youtu.be\n\n"
"http://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"http://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"http://m.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"https://www.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"https://youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n"
"https://m.youtube.com/watch?v=dQw4w9WgXcQ&feature=youtube_gdata_player\n\n"
"http://www.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
"http://youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
"http://m.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
"https://www.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
"https://youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n"
"https://m.youtube.com/watch?v=ishbTyLs6ps&list=PLGup6kBfcU7Le5laEaCLgTKtlDcxMqGxZ&index=106&shuffle=2655\n\n"
"http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
"http://youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
"http://m.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
"https://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
"https://youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n"
"https://m.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ\n\n"
"http://www.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
"http://youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
"http://m.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
"https://www.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
"https://youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n"
"https://m.youtube.com/watch?app=desktop&v=dQw4w9WgXcQ\n\n\n"
"http://www.youtube.com/watch/-wtIMTCHWuI\n"
"http://youtube.com/watch/-wtIMTCHWuI\n"
"http://m.youtube.com/watch/-wtIMTCHWuI\n"
"https://www.youtube.com/watch/-wtIMTCHWuI\n"
"https://youtube.com/watch/-wtIMTCHWuI\n"
"https://m.youtube.com/watch/-wtIMTCHWuI\n\n"
"http://www.youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
"http://youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
"http://m.youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
"https://www.youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
"https://youtube.com/watch/-wtIMTCHWuI?app=desktop\n"
"https://m.youtube.com/watch/-wtIMTCHWuI?app=desktop\n\n\n"
"http://www.youtube.com/v/dQw4w9WgXcQ\n"
"http://youtube.com/v/dQw4w9WgXcQ\n"
"http://m.youtube.com/v/dQw4w9WgXcQ\n"
"https://www.youtube.com/v/dQw4w9WgXcQ\n"
"https://youtube.com/v/dQw4w9WgXcQ\n"
"https://m.youtube.com/v/dQw4w9WgXcQ\n\n"
"http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
"http://youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
"http://m.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
"https://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
"https://youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n"
"https://m.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1\n\n"
"http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
"http://youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
"http://m.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
"https://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
"https://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
"https://youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
"https://m.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n\n"
"http://www.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
"http://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
"http://m.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
"https://www.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
"https://youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
"https://m.youtube.com/v/dQw4w9WgXcQ?feature=youtube_gdata_player\n\n\n"
"http://youtu.be/-wtIMTCHWuI\n"
"https://youtu.be/-wtIMTCHWuI\n\n"
"http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player\n"
"https://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_player\n\n"
"http://youtu.be/oTJRivZTMLs?list=PLToa5JuFMsXTNkrLJbRlB--76IAOjRM9b\n"
"https://youtu.be/oTJRivZTMLs?list=PLToa5JuFMsXTNkrLJbRlB--76IAOjRM9b\n\n"
"http://youtu.be/oTJRivZTMLs&feature=channel\n"
"https://youtu.be/oTJRivZTMLs&feature=channel\n\n"
"http://youtu.be/lalOy8Mbfdc?t=1\n"
"http://youtu.be/lalOy8Mbfdc?t=1s\n"
"https://youtu.be/lalOy8Mbfdc?t=1\n"
"https://youtu.be/lalOy8Mbfdc?t=1s\n\n"
"http://youtu.be/M9bq_alk-sw?si=B_RZg_I-lLaa7UU-\n"
"https://youtu.be/M9bq_alk-sw?si=B_RZg_I-lLaa7UU-\n\n\n"
"http://www.youtube.com/embed/lalOy8Mbfdc\n"
"http://youtube.com/embed/lalOy8Mbfdc\n"
"http://m.youtube.com/embed/lalOy8Mbfdc\n"
"https://www.youtube.com/embed/lalOy8Mbfdc\n"
"https://youtube.com/embed/lalOy8Mbfdc\n"
"https://m.youtube.com/embed/lalOy8Mbfdc\n\n"
"http://www.youtube.com/embed/nas1rJpm7wY?rel=0\n"
"http://youtube.com/embed/nas1rJpm7wY?rel=0\n"
"http://m.youtube.com/embed/nas1rJpm7wY?rel=0\n"
"https://www.youtube.com/embed/nas1rJpm7wY?rel=0\n"
"https://youtube.com/embed/nas1rJpm7wY?rel=0\n"
"https://m.youtube.com/embed/nas1rJpm7wY?rel=0\n\n\n"
"http://www.youtube-nocookie.com/embed/lalOy8Mbfdc?rel=0\n"
"https://www.youtube-nocookie.com/embed/lalOy8Mbfdc?rel=0\n\n\n"
"http://www.youtube.com/e/dQw4w9WgXcQ\n"
"http://youtube.com/e/dQw4w9WgXcQ\n"
"http://m.youtube.com/e/dQw4w9WgXcQ\n"
"https://www.youtube.com/e/dQw4w9WgXcQ\n"
"https://youtube.com/e/dQw4w9WgXcQ\n"
"https://m.youtube.com/e/dQw4w9WgXcQ\n\n\n"
"http://www.youtube.com/shorts/j9rZxAF3C0I\n"
"http://youtube.com/shorts/j9rZxAF3C0I\n"
"http://m.youtube.com/shorts/j9rZxAF3C0I\n"
"https://www.youtube.com/shorts/j9rZxAF3C0I\n"
"https://youtube.com/shorts/j9rZxAF3C0I\n"
"https://m.youtube.com/shorts/j9rZxAF3C0I\n\n"
"http://www.youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
"http://youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
"http://m.youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
"https://www.youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
"https://youtube.com/shorts/j9rZxAF3C0I?app=desktop\n"
"https://m.youtube.com/shorts/j9rZxAF3C0I?app=desktop\n\n\n"
"http://www.youtube.com/live/8hBmepWUJoc\n"
"http://youtube.com/live/8hBmepWUJoc\n"
"http://m.youtube.com/live/8hBmepWUJoc\n"
"https://www.youtube.com/live/8hBmepWUJoc\n"
"https://youtube.com/live/8hBmepWUJoc\n"
"https://m.youtube.com/live/8hBmepWUJoc\n\n"
"http://www.youtube.com/live/8hBmepWUJoc?app=desktop\n"
"http://youtube.com/live/8hBmepWUJoc?app=desktop\n"
"http://m.youtube.com/live/8hBmepWUJoc?app=desktop\n"
"https://www.youtube.com/live/8hBmepWUJoc?app=desktop\n"
"https://youtube.com/live/8hBmepWUJoc?app=desktop\n"
"https://m.youtube.com/live/8hBmepWUJoc?app=desktop\n\n"
"http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
"http://youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
"http://m.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
"https://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
"https://youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n"
"https://m.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json\n\n\n"
"http://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
"http://youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
"http://m.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
"https://www.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
"https://youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n"
"https://m.youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DEhxJLojIE_o%26feature%3Dshare\n\n"
"http://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
"http://youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
"http://m.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
"https://www.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
"https://youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail\n"
"https://m.youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DyZv2daTWRZU%26feature%3Dem-uploademail")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")