$re = '/(\%This\.|\&)[A-Za-z]+\.DESCR/m';
$str = '%This.oPosition.DESCR =
&data.DESCR =';
$subst = "name: $1; data = $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;