$re = '/(?<dir>[\-d])(?<permission>([\-r][\-w][\-xt]){3})\s+\d+\s+\w+\s+\w+\s+(?<size>\d+)\s+(?<timestamp>\w+\s+\d+\s+\d{1,2}:\d{2})\s+(?<name>.+)/';
$str = 'drwxrwxrwt 2 0 0 4096 May 18 14:50 deposit_slip';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);