using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!(\w+)\[)(\;(?!((\w+)((\;)(\w+)){0,}\])))";
string input = @"A;BB;C[1;22];DDD[11;2;33];EEEEE[1111]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}