const regex = new RegExp('(?<!(\\w+)\\[)(\\;(?!((\\w+)((\\;)(\\w+)){0,}\\])))', 'g')
const str = `A;BB;C[1;22];DDD[11;2;33];EEEEE[1111]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}