const regex = /^\w+\.\w+\.(?<my_host>\w{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+\\.\\w+\\.(?<my_host>\\w{4})', 'gm')
const str = `server.region.ab1dc2.mydomain.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}