$re = '/^\w+\.\w+\.(?<my_host>\w{4})/m';
$str = 'server.region.ab1dc2.mydomain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);