import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<(?!\\/)[a-zA-Z\\-0-9]+?(?:[\\s]*?[a-zA-Z\\-0-9]+?(?:=(?:\"[\\s\\S]*?\"|'[\\s\\S]*?')){0,1})*?[\\s]*?\\/{0,1}>)|(<\\/[\\S\\s]+?>)|(<!--[\\s\\S]*?-->)";
final String string = "<div class=\"main\">\n"
+ " <div>\n"
+ " <form id=\"cadastro\">\n"
+ " <input value=\"text\" />\n"
+ " </form>\n"
+ " </div>\n"
+ " <div>\n"
+ " <div>\n"
+ " <h1>Lorem ipsum dolor sit amet</h1>\n"
+ " <p>Lorem ipsum dolor sit amet</p>\n"
+ " </div>\n"
+ " </div>\n"
+ " <!-- sad asd asdasds adasd -->\n"
+ "</div>\n"
+ "<div>\n"
+ " <ul>\n"
+ " <li>item 1</li>\n"
+ " </ul>\n"
+ " teste\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}