const regex = /(<(?!\/)[a-zA-Z\-0-9]+?(?:[\s]*?[a-zA-Z\-0-9]+?(?:=(?:"[\s\S]*?"|'[\s\S]*?')){0,1})*?[\s]*?\/{0,1}>)|(<\/[\S\s]+?>)|(<!--[\s\S]*?-->)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<(?!\\\/)[a-zA-Z\\-0-9]+?(?:[\\s]*?[a-zA-Z\\-0-9]+?(?:=(?:"[\\s\\S]*?"|\'[\\s\\S]*?\')){0,1})*?[\\s]*?\\\/{0,1}>)|(<\\\/[\\S\\s]+?>)|(<!--[\\s\\S]*?-->)', 'gmi')
const str = `<div class="main">
<div>
<form id="cadastro">
<input value="text" />
</form>
</div>
<div>
<div>
<h1>Lorem ipsum dolor sit amet</h1>
<p>Lorem ipsum dolor sit amet</p>
</div>
</div>
<!-- sad asd asdasds adasd -->
</div>
<div>
<ul>
<li>item 1</li>
</ul>
teste
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}