using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!\/EHANCE).)*$";
string input = @"OPERA/9.80 (LINUX ARMV7L; OPERA TV STORE/6174) PRESTO/2.12.407 VERSION/12.51 MODEL/HISENSE-MTK5655 /EHANCE fghfghf fgh fgh fgh
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}