$re = '/^((?!\/EHANCE).)*$/';
$str = 'OPERA/9.80 (LINUX ARMV7L; OPERA TV STORE/6174) PRESTO/2.12.407 VERSION/12.51 MODEL/HISENSE-MTK5655 /EHANCE fghfghf fgh fgh fgh
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);