package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bfoo:\/\/\S+`)
var str = `Lorem ipsum foo://bar1234 dolor sit amet.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}