$re = '/\bfoo:\/\/\S+/m';
$str = 'Lorem ipsum foo://bar1234 dolor sit amet.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);