# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+#)/#\1/gm;t' <<< "Good 33912#This ice cream is so sweet1345#That's a very good bar"