$re = '/(\d+#)/m';
$str = 'Good 33912#This ice cream is so sweet1345#That\'s a very good bar';
$subst = "#\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;