import re
regex = re.compile(r"^\[([^\]]+)\] \[(오[전후] \d{1,2}:\d{2})\] (.*)$", flags=re.MULTILINE)
test_str = ("[철수] [오전 2:06] 메세지본문\n"
"위와 같은 문자열에서 사람이름, 시간, 메세지 본문을 따로 뽑아오고싶은데 정규표현식을 제대로 다뤄본적이 없어 고전중입니다 ㅠㅠ")
subst = "$3 - $2, $1"
result = regex.sub(subst, test_str)
if result:
print(result)