// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[([^\]]+)\] \[(오[전후] \d{1,2}:\d{2})\] (.*)$").unwrap();
let string = "[철수] [오전 2:06] 메세지본문
위와 같은 문자열에서 사람이름, 시간, 메세지 본문을 따로 뽑아오고싶은데 정규표현식을 제대로 다뤄본적이 없어 고전중입니다 ㅠㅠ";
let substitution = "$3 - $2, $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}