package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{3}\.\d{3}\.\d{1}\.\d{1}`)
var str = `192.168.1.1`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}