$re = '/^FILTER$(.*?)^ORDER$((?:(?!^FILTER$).)*)/sm';
$str = 'FILTER
test1 FILTER ORDER
ORDER
test2
FILTER
ORDER FILTER test3
ORDER
FILTER
ORDER';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);