import re
regex = re.compile(r"(?<!yellow.*).*blue(?=.*brown)")
test_str = ("yellow blue brown // shouldn't match\n"
"f blue brown // should match\n"
"sdff blue brown // should match\n"
"asdf f blue c // shouldn't match\n"
"yellow blue fblue b f brown // shouldn't match\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")