$re = '/^(?=.{8,16}$)(?=.*?[a-z])(?=.*?[A-Z])(?=.*?[0-9]).*$/m';
$str = 'hsdhsh0A
hsdhshuA
hsdhshuAhsdhsh8A
hsdhshuAhsdhsh8Aoi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);