using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{9}!?\b";
string input = @"blabla n123456789 bla bla 78 texto...
987654321! texto qualquer 12 blaa
123 bla blum 123741852 bobobl
blablum 12345678901 papumpa...";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}