import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{9}!?\\b";
final String string = "blabla n123456789 bla bla 78 texto...\n"
+ " 987654321! texto qualquer 12 blaa\n"
+ " 123 bla blum 123741852 bobobl\n"
+ " blablum 12345678901 papumpa...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}